Posts by cuphi

1) Message boards : Number crunching : ARM/ARM64 (Raspberry Pi) support (Message 1887)
Posted 20 Aug 2022 by Profile cuphi
...We have uploaded a new version for ARM forcing the static link to try to solve the issue. Could you check the new app? Especially the ones with problems. Thank you...

Thank *you* Jesús! My Odroid-N2+ is working on four DENIS tasks now.
2) Message boards : Number crunching : ARM/ARM64 (Raspberry Pi) support (Message 1871)
Posted 18 Aug 2022 by Profile cuphi
Well, maybe Jesus can tell us what's missing for sure. I am running Einstein@home WU's with no problems right now.
3) Message boards : Number crunching : ARM/ARM64 (Raspberry Pi) support (Message 1869)
Posted 18 Aug 2022 by Profile cuphi
I tested it now on Odroid-N2+, Odroid-M1, Odroid-C2 and Odroid-C4 running with Ubuntu 20.04.1 LTS/20.04.4 LTS.
All work fine.

On all my ARMs i have added some lib to work on all Boincprojects:

sudo apt install libsfstdc++6
sudo apt install libstdc++6

Maybe this help.

It turns out that libstdc++6 is already installed and that the libsfstdc++6 doesn't apply to my platform. It's for armhf and I running aarch64.
4) Message boards : Number crunching : ARM/ARM64 (Raspberry Pi) support (Message 1867)
Posted 18 Aug 2022 by Profile cuphi
I just tried an switching to Armbian's Jammy release ( and have the same error message. It seems that DENIS doesn't like Ubuntu based distros on this board.
5) Message boards : Number crunching : ARM/ARM64 (Raspberry Pi) support (Message 1866)
Posted 18 Aug 2022 by Profile cuphi
all the wu's go wrong
process exited with code 2 (0x2, -254)</message>
Process creation (../../projects/denis.usj.es_denisathome/DENIS_Myocyte_Beta_0.18_aarch64-unknown-linux-gnu) failed: Error -1, errno=2
execv: No such file or directory


All WU's are failing on my Odroid-N2+ with this same message.

Link to computer:

root@aarch64-chunk:~# uname -a
Linux aarch64-chunk 4.9.312-125 #1 SMP PREEMPT Sat Jun 18 18:58:41 UTC 2022 aarch64 aarch64 aarch64 GNU/Linux
root@aarch64-chunk:~# lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.4 LTS
Release:	20.04
Codename:	focal
root@aarch64-chunk:~# boinc --version
7.16.6 aarch64-unknown-linux-gnu
6) Message boards : Cafe : Why DENIS? (Message 1858)
Posted 16 Aug 2022 by Profile cuphi
I know people donate CPU time to distributed computing projects for a wide variety of reasons. So I making this thread so that we can all share our reasons for paying electricity bills and hardware purchases just to donate to this project.

Years ago, my mother died of a heart attack and the doctors couldn't tell us what caused it. It was "out of the blue and into the black." I couldn't accept the lack of answers and started digging deeper. I learned that for over 50% of all women their first heart attack is fatal. No one could say why. There are still many ideas but not any proof because very few studies in cartiological science are based on gender. At least not the big ones.

I am donating my money and CPU time to DENIS because it is looking for reasons at cellular level and therefor should save as many women as men.
7) Message boards : Number crunching : Myocyte beta 0.18 (Message 1857)
Posted 16 Aug 2022 by Profile cuphi
From my perspective things are looking great. I am less than 12 hours away from completing 7 consecutive days of work and have not had a single task error out. That is 7237 valid tasks and 480 tasks pending validation at the time I am writing this.
8) Message boards : Number crunching : Myocyte beta 0.18 (Message 1845)
Posted 9 Aug 2022 by Profile cuphi
Hello World.

I am new to the project and just finished my first batch of WU's. I see this at the end of log file for each WU:

05:14:49 (8752): called boinc_finish(0)
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory
profiling:/denis-myocyte:Cannot create directory

My computer: